Component: container
351 changelog entries across 85 version(s)
Releases by channel (stacked)
- fix veth interface left running after restarting a stopped container;
- improve container image extraction;
- add a Ctrl-] escape sequence to exit a stuck container shell;
- fix container interface handling on CHR;
- improve container image extraction;
- require the container device-mode to enable swap;
- improve host isolation when container is set to "privileged=yes";
- added "save" command to allow saving container images;
- added "swap-current" usage;
- added "swap-max" global and per-container limit;
- added ability to run containers in privileged mode;
- added initial support for RKE2;
- do not allow starting with empty default DNS list and no DNS override;
- do not print environment variables in log on container startup;
- fixed "start-on-boot" not retrying on certain startup errors;
- fixed container "devices" override to appear under "/dev";
- improved layer size calculation to avoid potential loops;
- improved support for containers;
- reduced writes to flash when running health check;
- use env "TERM=xterm" if no TERM variable provided when running shell;
- fixed missing config.json issue when upgrading from version 7.20.8 or older;
- fixed missing config.json issue when upgrading from version 7.20.8 or older;
- added "save" command to allow saving container images;
- added "swap-current" usage;
- added "swap-max" global and per-container limit;
- added ability to run containers in privileged mode;
- added initial support for RKE2;
- fixed container "devices" override to appear under "/dev";
- improved layer size calculation to avoid potential loops;
- fixed missing config.json issue when upgrading from version 7.20.8 or older;
- added "save" command;
- do not allow starting with empty default DNS list and no DNS override;
- do not print environment variables in log on container startup;
- fixed "start-on-boot" not retrying on certain startup errors;
- improved support for containers;
- reduced writes to flash when running health check;
- use env "TERM=xterm" if no TERM variable provided when running shell;
- added restart-policy=no/always/on-failure, stop-on-unhealthy, restart-count, restart-interval, restart-max-count properties;
- added support for noexec option to mounts;
- added support for USB audio devices for containers;
- allow disabling individual container environment variables without deleting them;
- allow picking mount source directories with the file picker in WinBox;
- allow setting memory-max globally and per container;
- allow user-defined mounts overriding /sys and /dev;
- check if root-dir does not exist before adding a container;
- clean up layers of non-existing containers;
- detect and show containers killed by out-of-memory killer;
- do not allow starting container/shell with non-existing user or group;
- draw graphs in container stats;
- fixed container entrypoint and shell override by user;
- fixed container layer size calculation;
- fixed container shell not working with multi-arg commands;
- fixed repull if root-dir of container was in tmpfs;
- fixed running "/container shell" with the correct user, if container user is set or overridden;
- improved errors at container start;
- improved running container instance memory usage;
- layers are now accessible under "Layers" tab;
- pass any container startup error message back to "run" and make it exit immediately;
- remove container backup directory if import fails;
- removed "Layers" button;
- show container size and container data size;
- show default DNS servers;
- show layer size calculation status;
- updated /dev/net/tun permissions;
- updated /dev/net/tun permission;
- fixed losing container after reboot;
- fixed issue where the container might not start after upgrading if root-dir was not set;
- improved error message if a container fails to start;
- check if root-dir is not used before adding a container;
- check if root-dir does not exist before adding a container;
- allow setting memory-max global and per container (additional fixes);
- added support for noexec option to mounts;
- added support for USB audio devices for containers;
- do not allow starting container/shell with non-existing user or group;
- draw graphs in container stats;
- remove container backup directory if import fails;
- show container size and container data size;
- show default DNS servers;
- added restart-policy=no/always/on-failure, stop-on-unhealthy, restart-count, restart-interval, restart-max-count properties;
- allow disabling individual container environment variables without deleting them;
- allow picking mount source directories with the file picker in WinBox;
- allow setting memory-max global and per container;
- allow user-defined mounts overriding /sys and /dev;
- clean up layers of non-existing containers;
- detect and show containers killed by out-of-memory killer;
- fixed container entrypoint and shell override by user;
- fixed container layer size calculation;
- fixed container shell not working with multi-arg commands;
- fixed losing container after reboot;
- fixed repull if root-dir of container was in tmpfs;
- fixed running "/container shell" with the correct user, if container user is set or overridden;
- improved errors at container start;
- improved running container instance memory usage;
- layers are now accessible under "Layers" tab;
- pass any container startup error message back to "run" and make it exit immediately;
- removed "Layers" button;
- show layer size calculation status;
- added support for zstd extraction;
- automatically stop/repull/start the container on repull or remote-image change;
- fixed issue where the container may not start after upgrading if root-dir was not set;
- improved error message if container fails to start;
- internal stability improvements;
- use the user-defined envs and envlist for container shell command;
- automatically stop/repull/start the container on repull or remote-image change;
- fixed issue where the container may not start after upgrading if root-dir was not set;
- improved error message if container fails to start;
- fixed nftables/iptables not working with "Message too long" error;
- added support for the shm_size setting;
- allow non-root user write to SMB share;
- changed default container registry to docker.io;
- do not mount tmpfs on /tmp and /run by default;
- do not start container if any volume is not mounted;
- fixed nftables/iptables not working with "Message too long" error;
- made container mounts writable by the user;
- added support for the shm_size setting;
- allow non-root user write to SMB share;
- do not mount tmpfs on /tmp and /run by default;
- do not start container if any volume is not mounted;
- fixed issue where containers may not start with large mounts;
- fixed nftables/iptables not working with "Message too long" error;
- made container mounts writable by the user;
- use the user-defined envs and envlist for container shell command;